[Bug] Speedometer bug

Bugs (physics-bugs,crashes during gameplay,UI-errors,etc...) belong here.
Post Reply
Stormpegy
Posts: 1
Joined: Thu Feb 18, 2016 2:29 am

[Bug] Speedometer bug

Post by Stormpegy » Thu Feb 18, 2016 2:44 am

Hey there, i was playing Celaria, trying to get a nice speedrun of the "connected" level and i noticed this bug.

Running open alpha v4

Bug info
Essentially, it seems the speedo works from when the player uses the movement keys ( WASD ) not the actual characters movement speed ( just a guess )

What happens is that if you walk in to a wall and continue holding a movement key, the game seems to think you are moving and the speedo continues to say you are traveling at speed, it seems to say anything between 5kp/h and 80km/h

How to reproduce the bug
Simply go on to any level and find a corner,
I tested this on "connected" and "acceleration"
Look in to the corner and hold a movement key, you can look anywhere between directly in to the wall and in to the corner and it will work.
Keep an eye on the speedometer while doing this, you will see what i mean

Video
Keep an eye on the speedometer when i walk in to the corner.

https://www.youtube.com/watch?v=Y16VffgVcl0


Really loving this game, keep up the amazing work
-Stormpegy

User avatar
Lewa
Site Admin
Posts: 158
Joined: Sun Nov 15, 2015 1:24 am

Re: [Bug] Speedometer bug

Post by Lewa » Thu Feb 18, 2016 4:38 pm

That's a bug in the physics- and collision detetection system.
I knew about this weird behaviour but i forgot about that. (Thanks for reminding me. XD)

It's fixed now. (I hope without breaking anything in the code XD) The fix will be included in the next alpha version.
Thank you for reporting that. :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest